Git system email delivery temporarily unavailable

Incident Report for BoxExchanger

Postmortem

Impact

Email notifications from the Git system (merge requests, mentions, password resets) were not sent.

Summary

Git email delivery was interrupted after our previous provider, SendGrid, unexpectedly suspended the account.

Resolution

Email delivery has been fully restored using the EU Mailgun service.
All outgoing messages now come from:

Git BoxExchanger noreply@git.boxexchanger.app

Posted Nov 08, 2025 - 16:15 UTC

Resolved

This incident has been resolved.
Posted Nov 08, 2025 - 16:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2025 - 16:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 08, 2025 - 15:35 UTC
This incident affected: Git system (Web UI, Gitaly).