Binance Spot Parser Not Updating Rates

Incident Report for BoxExchanger

Postmortem

To apply the latest updates for modules installed via Install Plugin, follow these steps:

  1. Go to Site Settings → Server section.
  2. Restart the required processes according to the plugin type.
  3. Locate the process exchanger-api-http and click Reboot.
  4. Confirm the reboot.
  5. Wait approximately 60 seconds.
  6. In the top-right corner of the page, click the refresh icon and verify that the process status shows updated a few seconds ago.
  7. Locate the process exchanger-api-parser-rate and click Reboot.
  8. Wait approximately 60 seconds.
  9. Again, click the refresh icon in the top-right corner and verify that the process status shows updated a few seconds ago.
Posted Mar 27, 2026 - 19:52 UTC

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 19:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2026 - 19:40 UTC

Update

The issue has been identified, and a fix is currently being tested. We are validating the changes before deployment to ensure market data updates resume correctly and remain stable.
Posted Mar 27, 2026 - 18:44 UTC

Identified

It has been identified that the Binance spot rate parser is no longer updating market data. The issue is caused by the deprecation and shutdown of the WebSocket stream !ticker@arr, which was previously used to receive tickers for all trading pairs.
Posted Mar 27, 2026 - 17:40 UTC